На днях обновлял один из обслуживаемых мной серверов и снова столкнулся с ошибкой при установке расширений.

Хотел, пойти уже по проверенному и долгому способу, но вдруг ко мне пришло более изящное и быстрое решение:

При ошибке:

Configuring for:
 PHP Api Version:         20090626
 Zend Module Api No:      20090626
 Zend Extension Api No:   220090626
 Cannot find autoconf. Please check your autoconf installation and the
 $PHP_AUTOCONF environment variable. Then, rerun this script.
 *** Error code 1

Делаем:

bash# export PHP_AUTOCONF=autoconf-2.68
bash# export PHP_AUTOHEADER=autoheader-2.68
csh# setenv PHP_AUTOCONF autoconf-2.68
csh# setenv PHP_AUTOHEADER autoheader-2.68

Проверяем, получилось ли что то у нас:

# set | grep PHP
PHP_AUTOCONF=autoconf-2.68
PHP_AUTOHEADER=autoheader-2.68

При таком же выводе командной строки — дальше как обычно:

# make install

Напоминаю всем копирующим мой контент о существовании закона "Об авторском праве".
В связи с этим, прошу во избежании конфликтов при копировании данного материала, ставить на него ссылку:

http://noted.org.ua/2558


Также, вы можете отблагодарить меня переслав любую сумму на любой кошелек WebMoney, для поддержания данного ресурса. Или просто админу на пиво ;)

Кошельки для получения благодарности:
R386985788805
U234140473141
Z147712360455

На данной странице нет комментариев, возможно они закрыты. Если Вы хотите оставить свой комментарий, перейдите на специально созданный раздел

Add your comment now

Please note: JavaScript is required to post comments.